TOOLS: require a python 2 interpreter for our scripts (PEP 394)
authorStefan Westerfeld <stefan@space.twc.de>
Thu, 28 Sep 2017 21:42:22 +0000 (23:42 +0200)
committerStefan Westerfeld <stefan@space.twc.de>
Thu, 28 Sep 2017 21:42:22 +0000 (23:42 +0200)
Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
tools/delta.py
tools/polyphasefir.py
tools/smeval.py
tools/sminstbuilder.in
tools/testvib.py

index 9e49c09..2a50a33 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2
 
 import sys
 
index 1ffcad5..9575234 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python2
 
 # FIR design for polyphase filter
 
index 3d65606..38618f8 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python2
 # -*- coding: utf-8 -*-
 # Licensed GNU LGPL v3 or later: http://www.gnu.org/licenses/lgpl.html
 
index fd9ae9e..a0528a8 100644 (file)
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python2
 
 # Copyright (C) 2011 Stefan Westerfeld
 #
index 1399dec..4e32dc3 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python2
 
 import math
 import os